Discussion:
buildbot can't find jessie stuff?
(too old to reply)
Gene Heskett
2017-05-25 22:27:57 UTC
Permalink
Raw Message
Greetings everybody;

I have a 2nd pi up and somewhat running, but when I was ready to install
linuxcnc to test my new build of the 7i90+3 ea 7i42TA's I find that
neither pi can obtain an updated list from the
http://buildbot.linuxcnc.org/ jessie master-rt or from master-sim. They
are basically jessie/raspian installs, whereas the 3 rt wheezy installs
tied to machines fail, but this wheezy on master-sim can update just
fine.

sudo update's output:
***@pionsheldon:~ $ sudo apt update
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie InRelease
Ign http://buildbot.linuxcnc.org jessie InRelease
Hit http://buildbot.linuxcnc.org jessie Release.gpg
Hit http://buildbot.linuxcnc.org jessie Release
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://buildbot.linuxcnc.org jessie/master-sim armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://buildbot.linuxcnc.org jessie/master-sim Translation-en_US
Ign http://buildbot.linuxcnc.org jessie/master-sim Translation-en
Ign http://buildbot.linuxcnc.org jessie/master-sim
Translation-en_US.UTF-8
Ign http://archive.raspberrypi.org jessie/main Translation-en_US
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_US
Ign http://archive.raspberrypi.org jessie/main Translation-en_US.UTF-8
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib
Translation-en_US.UTF-8
Ign http://archive.raspberrypi.org jessie/ui Translation-en_US
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_US
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/main
Translation-en_US.UTF-8
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_US
Ign http://archive.raspberrypi.org jessie/ui Translation-en_US.UTF-8
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free
Translation-en_US.UTF-8
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_US
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_US.UTF-8
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.

Whole lot of Ign's there. Not all LCNC's.

Am I screwed up, or does the buildbot have a problem?

Thanks all.

Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>
Gene Heskett
2017-05-26 00:53:18 UTC
Permalink
Raw Message
Post by Gene Heskett
Greetings everybody;
I have a 2nd pi up and somewhat running, but when I was ready to
install linuxcnc to test my new build of the 7i90+3 ea 7i42TA's I
find that neither pi can obtain an updated list from the
http://buildbot.linuxcnc.org/ jessie master-rt or from master-sim.
They are basically jessie/raspian installs, whereas the 3 rt wheezy
installs tied to machines fail, but this wheezy on master-sim can
update just fine.
...
Post by Gene Heskett
Am I screwed up, or does the buildbot have a problem?
There is currently no Jessie armhf buildslave.
We build for Jessie on i686 and amd64, but not for Jessie on armhf.
We build for Wheezy on armhf (and i686 and amd64), so that may be an
option for you.
We had a Jessie armhf buildslave for a while but it died, and i
haven't rebuilt it yet.
If you want to run Jessie on armhf you currently have to build from
source.
Got a tut squirreled away someplace? Most of what I have on the armhf
jessie is dated Dec 18, 2016, pretty old. I might be able to scrape up
a Sheckel or 2 if that would help?

ETA for a functional buildslave?

Thanks Sebastian

Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>
Sebastian Kuzminsky
2017-06-01 22:06:06 UTC
Permalink
Raw Message
Post by Gene Heskett
There is currently no Jessie armhf buildslave.
We build for Jessie on i686 and amd64, but not for Jessie on armhf.
We build for Wheezy on armhf (and i686 and amd64), so that may be an
option for you.
We had a Jessie armhf buildslave for a while but it died, and i
haven't rebuilt it yet.
If you want to run Jessie on armhf you currently have to build from
source.
ETA for a functional buildslave?
I restored the jessie armhf buildslave. 2.7 debs are up, master debs
are on their way.
--
Sebastian Kuzminsky
Loading...